Home Image Processing Tool Technical Details Browser Compatibility Source Code

Dog VISION
Copyright 2012 by András Péter
E-Mail: [email protected]

Browser requirements

The Dog Vision tool was conceived to do the image processing completely in the browser, without the need of any server side processing and extra data transfer. Because of this it relies on elements defined in the newest HTML5 standard. These are: the canvas element, data URI, file reader API, web workers. However not every major browser and especially not their older versions support all these elements.
The Dog Vision tool is able to function even in the absence of support for the file reader API (in this case the image file has to be sent to the server and back when opening it) and in the absence of web worker support (the page becomes unresponsive during image processing, and the browser might give a warning when processing larger images).
At the present (Q3 2011) three of the five major browsers support all the required functions: Chrome, Firefox and Opera. However with the above limitations the Dog Vision tool also works with Internet Explorer 9 and Safari 4/5. Internet Explorer 8 does not support the canvas element and data URIs longer than 32KB so Windows XP users should try one of the other browsers.
Albeit I'm personally a fan of Chrome, I have to say that at the present its JavaScript engine is running the Dog Vision tool a lot slower than other browsers (up to 3 times slower). So for the best user experience I suggest to use the newest version of Firefox or Opera.

Solomon Coder Yourwebhoster.eu